How can we help you today?

SharePoint Server 2013 / 2016 - Installation / Upgrade Failed Error - CBS-SP-I : The Solution Has Not Been Upgraded

Applies To

  • SharePoint 2016 On-Premise
  • SharePoint 2013 On-Premise

Issue


You are trying to execute Setup2016.exe or Setup2013.exe for Installation or Upgrade and you are facing following error



-----------------------------------Info: Deactivating 2 total activations of 1 feature(s) on 2 location(s).Info: Deactivating 0 feature(s) on 0 site(s).Info: Deactivating 1 web application feature(s) on 2 web applications.Info: Deactivating 1 web application feature(s) on 2 web applications. feature: f7c2582f-427f-4342-849c-b4ebf8a9c642 : ShortPoint.Foundation (f7c2582f-427f-4342-849c-b4ebf8a9c642)Info: Deactivating 1 web application feature(s) on 2 web applications. feature: f7c2582f-427f-4342-849c-b4ebf8a9c642 : ShortPoint.Foundation (f7c2582f-427f-4342-849c-b4ebf8a9c642)Info: ***** SOLUTION UPGRADE *****Info: CBS-SP-I : The solution has not been upgraded.
*Error: ***** ERROR ******Error: CBS-SP-I : The solution has not been upgraded.
 Exception: CodePlex.SharePointInstaller.InstallException: CBS-SP-I : The solution has not been upgraded. ---> CodePlex.SharePointInstaller.InstallException: CBS-SP-I : The solution has not been upgraded.
   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()   --- End of inner exception stack trace ---   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()   at CodePlex.SharePointInstaller.InstallProcessControl.TimerEventInstall(Object myObject, EventArgs myEventArgs)
  Inner Exception: CodePlex.SharePointInstaller.InstallException: CBS-SP-I : The solution has not been upgraded.
   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()-----------------------------------

Reasons and Solutions


Reason

Solution

Running setup as AdministratorPlease ensure you are running the Setup2016.exe / Setup2013.exe as farm administrator
One of the farm server has issue Please ensure on each Web front end and application server followings;
  1. They are connectable / accessible from server you are running Setup2016.exe / Setup2013.exe
  2. The Farm account you are running are admin in those servers
  3. Following services are running with SharePoint service accounts;        
    1. SharePoint Administration
    2. SharePoint Timer Service
Any other issueIf you made sure above points but still you are still facing the same issue, we recommend trying following;
  1. Stop the executing and try again
  2. Clean cache on each Web front end and application server and try again;
  3. Remove the ShortPoint.Foundation.wsp from your Farm and try again;

    Powershell

    Uninstall-SPSolution -Identity ShortPoint.Foundation.wsp
    Remove-SPSolution -Identity ShortPoint.Foundation.wsp


    Central Admin 

  4. Restart following services on each Web front end and application server and try again;
    1. SharePoint Administration
    2. SharePoint Timer Service


If at any stage, you feel like contacting us, please don't hesitate to do so!


Related Article

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.

World's best intranet sites are designed using ShortPoint

Get started today! Learn more
See all 17 topics

Start a trial

Ignite your vision. Install ShortPoint directly on your site, or play in sandbox mode. No credit card required.

Get started today

World's best intranet sites are designed using ShortPoint

Thousands of companies using ShortPoint everyday to design, brand and build award winning intranet sites.

Get started Learn more