Start a new topic

Known Issue: Horizontal Scrollbar not Shown for SharePoint OOTB List Web Part inside a ShortPoint Element

If you have  quite a wide SharePoint list with many columns, like this:



And you insert it into a ShortPoint element (let's say Section) which is shorter by width, you expect a horizontal scroll bar to appear.

Here is how it looks in Edit Mode:



Nevertheless, when you save the page and look at it in View Mode, the scrollbar is not there and the user only sees a part of the list without being able to scroll:




Doesn't look good, right?


The fix for this bug will be released very soon. In the meanwhile, let us show you a simple workaround that will bring back the missing scroll bar and make users happy again.


Here are the steps:


1) open the ShortPoint Dashboard (Site Settings > ShortPoint Dashboard)
2) choose ShortPoint Theme Builder
3) click Customize my Site
4) in the Theme Builder left-side panel, please navigate to Utilities > Custom CSS
5) paste the following code:

.shortpoint-force-sharepoint-responsive .ms-rte-wpbox:not([class*=shortpoint]) {
overflow-x: auto;
}


6) click Apply and Publish. Wait for the Theme Builder to finish publishing.
7) Reload the page you are working with. After reload, it should show the list web parts with a horizontal scrollbar.


Here is the result:



Looks much better now! 


Hope this temporary solution will be useful to you.



Login or Signup to post a comment